06 Déc 2017

4 raisons pour lesquelles vous devriez utiliser PHP7 Spécial

joomla php7

Avec la perspective de Joomla 4 pour l'année prochaine, nous aimerions vous sensibiliser sur l'intérêt de la mise à niveau vers PHP7.

Joomla 4 nécessitera PHP7 pour fonctionner, comme nous l'avons indiqué dans cette annonce. La plupart des hébergeurs proposent déjà PHP7 dans leurs offres et il devrait être assez facile de modifier votre version PHP. (avant de le faire, assurez-vous d'effectuer une sauvegarde) Sinon, contactez votre hôte dès aujourd'hui.

Laissez-nous vous donner 4 raisons pour lesquelles vous ne devriez pas attendre pour faire la mise à niveau vers cette version PHP.

PHP7 est la meilleure version

Facile à dire bien sûr, mais PHP7 apporte une amélioration de performance qui rend votre site deux fois plus rapide en utilisant 50% de mémoire en moins par rapport à PHP5. De plus, PHP7 est aussi plus sûr et vous permet d'en faire plus en tant que développeur.

Joomla 4 sera impressionnant

Joomla 4 apportera d'énormes améliorations pour les utilisateurs et les développeurs. Un code épuré, un nouveau Framework, de nouvelles fonctionnalités et bien plus encore. Bootstrap 4 sera implémenté dans le noyau, il y aura 2 nouveaux templates (frontend et backend), sans oublier le nouveau gestionnaire médias qui sera apprécié par beaucoup.

Comme Joomla 4 est encore en cours de développement et prévu pour la seconde moitié de 2018, la liste des fonctionnalités impressionnantes continuera de s'allonger et sera annoncée avant son lancement en version stable.

Un nouveau Framework

Le nouveau Framework (version 2.0) qui arrivera avec Joomla 4 apportera quelques améliorations majeures. L'API de base de données prend en charge nativement les instructions préparées, ce qui constitue une amélioration majeure de la sécurité. Stocker des données cryptées sera désormais possible avec un composant Keychain plus modulaire. Les outils de ligne de commande peuvent être améliorés et sécurisés grâce au nouveau composant Console.Pour une liste complète des caractéristiques, consultez la feuille de route.

Une version plus sûr et prise en charge

Les versions antérieures à PHP 5.6 ne sont plus prises en charge pour les corrections de sécurité. Si une vulnérabilité est trouvée dans PHP5.3, aucune correction ne sera proposée et votre site deviendra vulnérable. En utilisant la dernière version, vous saurez toujours que ces problèmes seront pris en charge, et que les mises à jour seront disponibles très rapidement.

Comme PHP7 est la dernière version majeure, elle sera supportée pendant une longue période (y compris les versions mineures) de sorte que votre site Joomla 4 sera facilement gérable jusqu'en 2025.

Mais, mais... Et si je ne peux pas mettre à niveau?

Une chose importante à retenir est que Joomla 3.9 sera supporté pendant deux ans après sa sortie. Cela signifie que vous pouvez gérer votre site Joomla 3 confortablement jusqu'en 2020, mais vous allez manquer toutes les fonctionnalités et avantages de Joomla 4. Mais soyons honnêtes, si votre hébergeur ne supporte pas PHP7 maintenant, il serait peut-être bon de chercher un autre hébergeur.

Nous sommes fermement engagés à faire que la prochaine génération de Joomla, soit la meilleure génération avec le sentiment que l'adoption de PHP7 aidera à fournir un produit de la plus haute qualité pour nos utilisateurs.
M. Babker

Traduction libre de l'article 4 reasons why you should get PHP 7

Dernière modification le jeudi, 07 décembre 2017
Connectez-vous pour commenter

A propos de l’AFUJ

L'AFUJ est l'association francophone des utilisateurs de Joomla. Cette association à pour but de promouvoir Joomla dans toute la francophonie.

Contactez l'AFUJ  

Réseaux sociaux